An introduction to the Xcas interface

Bernard Parisse, University of Grenoble I

©2007, Bernard Parisse.
Released under the Free Documentation License, as published by the Free Software Foundation.

Abstract

This paper describes the Xcas software, an interface to do computer algebra coupled with dynamic geometry and spreadsheet. It will explain how to organize your work. It does not explain in details the functions and syntax of the Xcas computer algebra system (see the relevant documentation).

1 A first session

To run xcas,

- under Windows
  you must select the xcasen program in the Xcas program group

- under Linux
  type xcas in the commandline

- Mac OS X.3
  click on the xcas icon in Applications

You should see a new window with a menubar on the top (the main menubar), a session menubar just below, a large space for this session, and at the bottom the status line, and a few buttons. The cursor should be in what we call the first level of the session, that is in the white space at the right of the number 1 just below the session menubar (otherwise click in this white space). Type for example 30! then hit the return key. You should see the answer and a new white space (with a number 2 at the left) ready for another entry. Try a few more operations, e.g. type 1/3+1/6 and hit return, plot(sin(x)), etc.

You should now have a session with a few numbered pairs of input/answers, each pair is named a level. The levels created so far are all commandlines (a commandline is where you type a command following the computer algebra system syntax). Inside Xcas, there are other kinds of levels, the most frequently used being comments, programs, geometry (2-d or 3-d) and spreadsheet levels.

The most important editing operations are

- modify an existing input field and reevaluate it after it has been modified by hitting the return key.

- select a level or a group of levels with the mouse. Selected level(s) may be moved or erased.

- use the main menubar to enter an Xcas function name, for example Math->Entier->is_prime.
  (A short help on the function will be displayed in the messages at the bottom, press the msg button if you don’t see it)
copy-paste, which follows Windows rules (Ctrl-C copy, Ctrl-X cut, Ctrl-V paste) or Linux rules (select with the mouse to copy, paste with the middle mouse button or with the paste button at the bottom).

Online help may be accessed using the main menubar Help->Index (short help) and Help->Manuals (long help currently available in French only, you are welcome to volunteer for translation!). If you know a function name, you can also type the beginning and hit the tabulation key (at the left of the Q key on a qwerty keyboard) or the ? key.

You can save your work using the Save button or the File session menubar (not the main menubar). Other disk and printing operations are also accessed from the session menubar.

The software configuration parameters are grouped in three sections: cas (computer algebra system), geo (geometry and graphics), general (everything else). The main menubar Cfg item will help you modify the configuration.

There are four kinds of buttons at the bottom of the Xcas window:

- at the left, blue switch buttons that make appear or disappear the short online help, a scientific keyboard, a bandeau (like the menu but as persistent buttons), the message area.
- in the middle left the TeX button that is used to convert in \LaTeX a selected mathematical formula or a submatrix (inside the spreadsheet)
- in the middle the cas status button (in red, displaying the number of digits, the angle unit, etc.), you can hit it to modify the cas configuration
- at the right, a STOP button to interrupt a computation, a backspace button (useful for devices without keyboard like PDA), a paste button and a return button.

In the next sections, we will explain in more details the capabilities of the Xcas interface: online help, the different kinds of levels, the management of sessions and the configuration.

## 2 Online help

If you know a commandname but want to check the syntax, type the beginning of the commandname, then the tabulation key, this will display the command index, with the current position at the first command after the commandname begin. You have a short description and a few examples displayed. Clicking on an example should complete the commandline with this example. You can get more details on the command (currently available in French only) with the Details button.

If you don’t know the commandname, you might find them using the menus or browsing the (French) table of contents of a manual. If you know the TI89 or the Maple language, you can try their commandnames.

## 3 Level types

Each session is a numbered collection of levels, each level has a type like commandline, comment, spreadsheet, program, 2-d or 3-d geometry or logo.

### 3.1 Commandline

If no commandline is available, you can get a new one by the Edit->Add->entry menu. You can modify existing commandlines or write in a new commandline. The following shortcuts are available
• Tab: show completions
• Enter: parse and evaluate the current commandline. You can type Enter while the cursor is at any position. A new commandline will be added if it was the last level of the session or if the next level is not a commandline.
• shift-Enter: make a new line in the current commandline
• Ctrl-C: copy selection to clipboard
• Ctrl-V: paste clipboard
• Ctrl-X: cut and copy selection to clipboard
• Ctrl-U: erase commandline without copy in the clipboard
• Esc: erase commandline with copy in the clipboard
• Ctrl-Z: cancel last edit command
• up and down: move in the current commandline if it is a multiline commandline
• PageUp and PageDown: move to the previous or next level
• Ctrl-Up and Ctrl-Down replace the selection with the previous or next command that has been validated in a previous commandline (history saving mechanism).

When you evaluate a commandline, a log output will be displayed (written in blue over white by default), and the answer, which might be an equation or a graphic (2-d or 3-d) widget (if the answer is a graphic object. For lists, the decision is taken according to the type of the last object displayed).

If you do not want to see the answer displayed (for example if you store a large matrix in a variable), just finish your commandline by ;;

3.2 Comments

Comments are inserted using the Edit->Add->comment menu. They are by default written in green instead of red over white. Comments are not evaluated when pressing Enter (the effect is to put the cursor to the next level).

3.3 Programs

Programs may be written in a commandline if they are one or two lines long, but for more complex programs, it is a good idea to put them in a separate program level, using the Edit->Add->program menu. This will open an editor in a new level.

The editor has its own menu, you can open or import an existing (program) file inside the current text, save or export the current program. You can also use the editor menu to insert programming structure. There are buttons to find the next occurrence of a search string, to parse the current program (errors are displayed in the messages area) and to save the program (the current filename is displayed at the right of the save button).

The keywords of the language are highlighted. In Xcas programming mode, the tabulation key may be used for indentation (experimental feature).

Tip: before pressing the OK button, make sure the programming syntax is the right one (look in the status area, if you need to change the syntax, hit the red status button at the bottom middle).
3.4 Geometry and graphics

A graphic output is made of a 2-d or 3-d scene with controls. A geometry session is the display of a graphic scene representing the objects of the commandlines that are on its left. You can use special objects called parameters to have interactive geometry, and in 2-d geometry, you can also move points. The Geo menu contains commands for geometry (whose names are in French).

3.4.1 Common features

A menu is available below the controls, it contains items to print and control the screen. You can export a graph to encapsulated postscript and to PNG (you must have the converting tools netpbm installed, this is installed by the Xcas installer under Windows).

Title and axis legends must be part of the command(s) that generate the graph or geometry window. For example, try this on a commandline

\[ f(t) := \sin(t); \text{title} = "Graph of f on a period", \]
\[ \text{labels} = ["t", "f(t)"], \text{legend} = ["cm", "m"], \text{plot}(f(t), t = -\pi..\pi) \]

The controls are common to 2-d, 3-d graphics or geometry. You can move left, right, up and down the window, redefine it using coordinates, zoom in and out, pause and restart an animation. In 2-d, the coordinates of the mouse are displayed while it is in the graphic area. In 3-d, you can rotate the representation along the current x, y, z axis with a mouse drag outside of the scene rendering, or by hitting the x,X, y,Y and z,Z key (when the focus is in the 3-d scene).

Note that the controls apply only to the visualization, not to the creation of graphic objects. For example, if you create a plot of a function, the discretisation parameters for this plot (e.g. minimal value for \(x\)) are fixed and will not change if you move the minimal visualisation value using the controls. You must recreate a graphical object if you did not choose correctly the parameters. For example if you run the command \(\text{plot}(\sin(x))\), the minimal value for computation of \(x\) will be the default value (Xmin from the Geo configuration). If you move the minimal value of \(x\) for visualization below Xmin, you will not see the plot there. To see the plot below Xmin, you would have to specify something like \(\text{plot}(\sin(x), x = -20..0)\) and validate the commandline. This limitation does not apply to point, line and circles which will always be drawn if they are visible.

3.4.2 2-d geometry

Use the Edit->Add->geometry menu to make a new 2-d geometry session. This will open in a level a subsession at the left, the 2-d screen in the middle, and the controls at the right. If there are parameters, they will be below the controls at the right. The subsession is a list of commandline levels. Evaluation of a commandline level will automatically reevaluate all levels below (i.e. with a higher level number), therefore if you use one level to define an object and modify the definition of this object later, all objects depending on this object will be modified. Modification of a level defining a point or a 1-d parameter can be done interactively with the mouse either in the geometric screen or in the parameter area (below the controls).

The geometry level has a mode, which affects how the mouse behave. In point mode, the mouse can be used to define new points or segments. To define a new point, just click somewhere not near another point or segment. To define a segment, push the mouse button at the beginning, move the mouse, release the mouse at the end of the segment (if you release the mouse out of the screen, the segment will be cancelled). In pointer mode, you can move an existing point, push the mouse near the point (when the mouse is near enough, it will show a different cursor) and move the mouse, release it at the new position. You can draw a few more complex object with
the mouse using the other modes. You can also type Xcas commands (from the Geo menu) in a commandline level.

To erase a geometrical object, just select the levels in the subsession at the left, and use the Edit->Suppress levels menu.

For example, you can click three points with the mouse (in point mode), this will create 3 levels with definitions for points A,B,C. Then you can make the circle containing A, B, C with the circonscrit command (menu Geo->Circles) by entering the following command in the next commandline

c:=circonscrit(A,B,C)

### 3.4.3 Parameters

Parameters are real values which can move in a fixed interval, e.g. between -5 and +5. The real value may be changed by moving a cursor with the mouse below the controls at the right of the geometrical representation. There are two kinds of parameters: formal and numeric parameters. Formal parameters have a formal name which is used in all exact calculations, and a numeric value which is used for all numeric evaluations. They can be used to do a CAS proof of a geometrical theorem, while displaying a figure. Numerical parameters evaluate always to their numerical value.

To add a new parameter, use the Edit menu of the geometry level. For example, add a level with \( f(x) := a \cdot x^2 + b \cdot x + c \) then define 3 parameters named a, b, c and add the command \( \text{plot}(f(x)) \), then move one of them. You can also add a level \( \text{mini} := \text{solve}(\text{diff}(f(x),x)) \) and \( M := \text{point}(\text{mini}[0], f(\text{mini}[0])) \) to display the minimum. Note that the coordinates of M are displayed in terms of a and b in the subsession at the left. You must add a level with \( e \cdot \text{evalf}(\text{coordonnees}(M)) \) to see the current value.

### 3.4.4 3-d geometry

3-d geometry is based on the same principle than 2-d geometry: a subsession at the left and the representation in the middle. Mouse interaction outside the representation will change the viewpoint, inside the representation it will depending on the mode draw points, segments, ... according to the mouse plan displayed above (all mouse clicks are supposed to refer to this plan, which is perpendicular to the visualisation axis).

### 3.5 Spreadsheet

Use the Edit->Add->spreadsheet menu to add a spreadsheet level. You will see a small configuration screen where you can change the number of rows/columns, if an attached graph is displayed, and also a variable name that you can use to get values from commandlines outside of the spreadsheet (using the matrix notation, e.g. \( a[1,2] \) will return the value of the cell at row 2, column 3 in Xcas syntax mode, or at row 1, column 2 in other syntax modes). You can modify the spreadsheet configuration by hitting the status line above the cells or with the spreadsheet File->variable name menu later). If you have choosed to display the graph inside the spreadsheet configuration, it will dynamically display all cells that evaluate to a graphic object.

A cell may contain a fixed value (any valid Xcas object: integer, real, symbols, algebraic objects, strings, ...) or a formula depending on other cells. The syntax for formulas is the same as for many spreadsheet, begin with a \( = \), then enter an algebraic expression where other cells are represented using a symbol made of the column name (e.g. A) and the row number (e.g. 1). When copying cells, cell dependance in a formula is considered relative unless you write a dollar ($) sign before the column name or row number. You can enter an area instead of a cell name, an area is always a rectangular area, it is made of two cell names separated by .. representing opposite vertices of the rectangular area.
To enter a new value or formula in a cell, click on the cell, then enter your value or formula with the keyboard. As soon as you type a normal character, the focus will move from the sheet to the commandline above the sheet. To help enter formula, you can use the mouse to select a cell or a cell area. Once the value or formula is correct press the enter key to validate it. You can cancel your edit at any time by pressing the Esc key.

To modify a cell value, click on the cell so that the value or formula is displayed in the commandline above, then click in the commandline, modify it and press Enter (or Esc to cancel).

You can move in the sheet using the mouse or the direction keys, or using the "goto" input value at the topleft of the sheet. Just enter a cell name then enter to move there. If the cell does not exist, the sheet will be enlarged to make it exist. You can also enter an area in the "goto" input value to select this area without the mouse. You must use the "goto" input value to make special selections that are not connected areas, for example A1..B3,D,F will "select" the tabular with rows 1 to 3 and columns A, B, D and F. You can copy and paste a rectangular area with the mouse like this: select the rectangular area with the mouse, click on the target cell, click on the commandline, type Ctrl-U to erase the previous value then click on the middle button and type enter.

If you want to copy a cell formula to an area of the spreadsheet, push the right bottom part cell (when the mouse is on the right area of the cell, it will display a different cursor) and move the mouse over the area you want to copy, then release the mouse. You can also copy cells using a menu item in the spreadsheet Edit menu, you can either copy to the left, or to the bottom, or to a rectangular area previously selected with the mouse (in this case the cell which was below the mouse when you pushed the button will be copied to the rectangular area).

The spreadsheet can be saved, exported, imported, etc. using the spreadsheet File menu. The spreadsheet is also saved as part of the session (but not as a standalone spreadsheet) when you save the whole session. When you load a session, the spreadsheet will not be evaluated automatically, you must reeval it with the reeval button explicitly (or modify one cell).

Xcas does not provide filters for native binary spreadsheet formats, but you can import spreadsheet from other softwares or data using copy/paste or by saving them in the text CSV (comma separated values) format: cells values must always be separated by the same character e.g. a comma, and another character is used to start a new row like a newline. For example, you can select a spreadsheet area inside Open Office and paste it inside Xcas. If you want to import formulas instead of values, use the Tools->Option menu of Open Office, find the spreadsheet Display item and check Formulas. Select the area inside Open Office, then paste at the same upper left cell position inside Xcas. Alternatively you can save the spreadsheet in CSV format inside Open Office with the File->Save as menuitem, then select CSV in the choosebox below. Then inside Xcas, use the File->Insert CSV menu item, select the file, change the separators if Xcas made a bad guess. Note that Xcas must use row numerotation starting at 1 instead of 0 for Open Office CSV formula import (this is the default).

Click on the status line or select inside the Edit menu for configuration and sheet modifications operations. Configuration operations should be self-explanatory, except for matrix fill cells: when entering a matrix in the commandline, you can choose between two modes, either the matrix will fill a rectangular area of cells, or it will fill only one cell.

The Stats menu is useful to make statistic plots in the corresponding graph. When you make a graph using this menu, you will have to select the data area where the statistic function will be applied (e.g. a polygonplot on A1..B10) and a target cell. The target cell is a regular cell which was empty and will contain the formula defining the graphic object that will be displayed. If you check the value box, the graph will not change later, but if you don’t check the value box and modify one data cell later, the
graph will be updated like any cell depending on this data cell would be.

3.6 Logo

To add a logo session, use the File->Add-> menu. A logo level is made of three parts, the graphic display in the middle, a subsession of commandlines at the left and an editor at the right. Commandlines are executed as in a main session (commandlines below an evaluated command are not reevaluated unlike in a geometry session). The editor records all commands.

In a logo level, you can pilot a turtle, giving it orders like forward 10 steps, turn left or right, etc. It will display a trace using a pen with a defined color. You can use any language construction of Xcas to program the turtle moves. The current language use French commandnames (e.g. avance=move forward, etc.), the most important commandnames are available by clicking on the buttonbar below the turtle screen (check that the cursor is on a commandline before clicking on the button corresponding to the command you want to enter). Most commands have a default argument (e.g. 10 for avance), if you want to add parameters, do not add parenthesis. Logo commands use the same syntax as the return statement, if you want to specify priorities, put parenthesis around the command and arguments, like this (hasard 10).

4 Session management

Xcas may open different sessions, each with its own levels. You can move levels inside a session or inside different sessions.

You can move one level in the session, push the mouse on its level number and release it at the destination. If you want to move some contiguous levels, click on the first level, then shift-click on the last level (that is click on the mouse while pushing the shift key). You can now move these levels by pushing the mouse in the selected area and release it at destination. You can also copy these levels in another session by moving the selection to the other session. You can delete the selected levels. You can paste the selected levels elsewhere by clicking with the middle mouse button on another level number. You can merge the selected levels in a single level. You can also group the selected levels in a section and give it a section name, sections may be folded or unfolded.

The File menu of a session will let you save/export/load/import a session in/from the current session. The Session menu from the top menu will let you insert a new session.

5 Configuration

There are three main categories of configuration: CAS configuration for the computer algebra commands, geo configuration for the default graphic options when creating a new graph and general configuration for other configuration items (like colors or browser for help display, etc.). The first one is accessed by the red cas at the bottom middle. All configuration items are also accessible using the main Configuration menu.

6 Customization

You can alter part of the main menubar, by editing a file named xcasmenu, either system-wide for the administrator (in the Xcas doc/en subdirectory), or for you only (in the directory where you start xcas ). The same applies for the Examples item,
the filename being xcasex. The file keywords may be used to translate Xcas commandnames in another language.